Bridge Wallet Closed Beta

Welcome to the feedback thread for the Bridge Wallet closed beta test :space_invader:

The goal of this test is to collect your bug reports, ideas, suggestions and feature requests on Bridge Wallet and its features, interface, experience, design.

Tell us what you like and what you don’t!

Main tasks

You are free to test the app as you want, but below are some processes we would like you to test with particular attention:

  • The identification process
  • The token trading functions (buy/sell buttons)

Useful information

  • Make sure you have version 1.0.16 or above installed
  • This closed beta test takes place on testnet.
  • When you first launch the wallet, you can restore an existing Ethereum address or create a new one. We would ideally like you to test both, but if you restore an existing address make sure to use an empty address.
  • When you do the identification process, you don’t have to provide real information and documents.
  • The identification process will be manual on our side for this test, so please be patient when waiting to receive a confirmation.
  • A special “Request Funds” button has been placed on the wallet’s main screen that you can use to get:
    ** 1 ETH
    ** 1,000 m-EUR
    ** 1,000 MPS tokens
  • Once you identify, you will also receive 1,000 m-CHF in your wallet to test the differences between a tokenized currency that is accessible without prior identification and one that requires it.

Bug reporting

If you find bugs when testing the app, make sure to provide as much information as possible to help us identify the problem:

  • Provide a screenshot of the problem when possible
  • Provide the screen on which the problem occurred
  • Describe the issue in detail

What is the Bridge Wallet?

Bridge Wallet is a mobile app providing a simple interface to interact with Ethereum addresses and tokens issued on the Bridge ecosystem.

Here are the main features of the wallet:

  • Access an existing Ethereum address or create a new one (non-custodial)
  • Send and receive Ethers and ERC20 tokens
  • Add and withdraw tokenized fiat currencies
  • Browse, buy and manage digital assets issued on Bridge
  • Manage events of Bridge assets such as shareholder voting, dividend payout, etc.
  • Create and manage a single KYC profile for all your Bridge assets
  • Link multiple Ethereum addresses to that profile
  • Buy and sell assets with no concept of deposit/withdrawals but allowances given to the smart contract, with direct P2P swaps taking place upon match

Please note that the features you test in this closed beta won’t necessarily be included in the public release of the app, but be included in later versions.

Who is it for?

  • Investors in tokenized assets
  • Holders of cryptocurrencies

Closed beta dates:

  • Start: 22/01/2020
  • End: 05/02/2020

Rewards

Active participants in the beta test will receive a gift for their effort :gift:

Release

Once the closed beta is over, we will correct the bugs found and implement the feedback received when possible. We’ll reserve a few weeks to do this properly, after which the public version will be released.

Post your test feedback below! :point_down:

1 Like

Has the app been published yet? I get an error message that the app has not been published yet, or my account is wrong.
My account is the same as the email I registered for the beta testing. Maybe not published in Hong Kong Google store yet, I’ll try again tomorrow.

For those who have this problem on Android, please try this:

Reset the Google Play app’s cache:

  1. Force close the Google Play app
  2. Open the Settings app
  3. Go to Applications > Application Manager > Google Play Store > Storage
  4. Click Clear Cache
  5. The Google Play app’s cache should now be reset. Try again by clicking here.
1 Like

Thanks Yann!

So I’ve tried to generate a new address and got a bug. I used “Generate a Seed Phrase” and “generate a Split Seed Phrase” and got the message “Unfortunately, Bridge has stopped.” on both options.
It looks like the wallet did made an address (see last screenshot), but because of the error I coudn’t get my backup.

1 Like

I would like to recommend other ways to import a ETH address.

  • Hardware wallet, Trezor, Ledger, etc. (maybe not possible with an app)
  • Private key (with carefull warning, private keys are dangerous)
  • Keystore JSON

Also, the $ values are not correctly displayed yet. Also on MPS, but they are only on Forkdelta so not really trading.

I made a transaction of MPS and it made a contract call with some ETH as fee. Worked very good.
My ETH balance has updated on the “Currencies” tab, but not on the Ether tab (the contract call, what costed ETH as fee also isn’t on the ETH Activity).
See screenshots below:



1 Like

So I made an ETH address on MyCrypto with 12 seed phrase:

0x0c3af72ebed0803e2370603ae6b55c64fdb8778d

I put the 12 seed phrase in the Bridge wallet and got this ETH address in return:

0x929d495DCb58ED97f74E63A1D06DAD35B32a8cec

Shouldn’t they give the same address in return?

1 Like

Thanks Yann.
Tried clearing cache, but no luck. I’ll keep trying to troubleshoot.
Great feedback from murcmurc!!

Hey Haywire, thanks :slight_smile:
I had an issue being signed in on another Gmail account.

Make sure you have the correct Gmail and then click Yanns link again:
https://play.google.com/apps/internaltest/4698080068441737100

1 Like

Do you still get the error message when clicking on the new link I posted in my previous reply?

1 Like

The derivation path and the network are not the same, you need to switch MyCrypto to the Ropsten Network (bottom-left of MyCrypto). The address displayed by the wallet should be the second one.

1 Like

unfortunately, yes.
I cleared cache for google play, chrome, signed out and signed into correct account, but still get an error message.
Thanks for your help Yann, Murc Murc!

1 Like

Ah okay, thanks.
I didn’t know that matters :blush::ok_hand:

1 Like

That’s weird… I don’t know how to help, maybe try another phone? If you have one extra :slight_smile:

1 Like

Thanks for your help!
I sent an email to get my other google account access to the app :smiley:

It’s also possible to skip all the seed words and get a wallet. I don’t know if it chooses seed words random then or not but I think it should be disabled. Otherwise people will get confused.

I would submitted a screen recording but only pictures are allowed here :wink:

Adding a price graph on here would be nice to see.

Also to get here you need to press Assets>MPS>buy>advanced
A graph on this screen would be sweet aswell. It would be easier for people to find.

Hi all,

I just download the app and here is my first bug/proposition.
First screen, maybe check for complexity to avoid people use one char password.
Second screen, I choose “créer un nouveau portefeuille” (in french). I next have a choice between two options that sounds like a Cornelian choice to me :wink:


However, whatever I choose, the application crashes with log :

com.facebook.react.common.JavascriptException: Invariant Violation: Element type is invalid: expected a string (for built-in components) or a class/function (for composite components) but got: undefined.

This error is located at:
in L
in RCTView
in l
in Styled(l)
in S
in Connect(S)
in c
in l
in P
in RCTView
in RCTView
in f, stack:
Zl@97:85823
d@97:36029
m@97:37308
ai@97:47643
Vl@97:81668
Ml@97:70036
Ul@97:67144
Ul@-1
Pl@97:65839
Pl@-1
@97:25495
unstable_runWithPriority@175:3915
sn@97:25442
cn@97:25377
_e@97:88686
Ne@97:13582
Ue@97:13755
receiveTouches@97:14547
value@44:3676
@44:832
value@44:2930
value@44:804
value@-1

at com.facebook.react.modules.core.ExceptionsManagerModule.reportException(ExceptionsManagerModule.java:71)
at java.lang.reflect.Method.invoke(Native Method)
at com.facebook.react.bridge.JavaMethodWrapper.invoke(JavaMethodWrapper.java:371)
at com.facebook.react.bridge.JavaModuleWrapper.invoke(JavaModuleWrapper.java:150)
at com.facebook.react.bridge.queue.NativeRunnable.run(Native Method)
at android.os.Handler.handleCallback(Handler.java:873)
at android.os.Handler.dispatchMessage(Handler.java:99)
at com.facebook.react.bridge.queue.MessageQueueThreadHandler.dispatchMessage(MessageQueueThreadHandler.java:26)
at android.os.Looper.loop(Looper.java:201)
at com.facebook.react.bridge.queue.MessageQueueThreadImpl$4.run(MessageQueueThreadImpl.java:225)
at java.lang.Thread.run(Thread.java:764)

Nevertheless, when I come back to the application, the adress seems to have been created. So I don’t have my passphrase. Quite confusing…


I push on the “Demander des fonds de tests” in “Portefeuille” side. I notice that the $ conversion just under figures is not up-to-date when I received funds.
.

I then decided to go to “Paramètres”, and click on “Mon profil”. If I decide to change mind and click the back android button, I loose the menu “Portefeuille, Activité, Adresses, Paramètres”. If I click again on the back android button, it reapears.

In the network settings menu, my mother wouldn’t be able to figure out what it’s all about… Maybe there should be a warning, or a button with an explanation of what it’s all about.

On the M-CHF (I haven’t passed the KYC yet), I didn’t understand the limitations. I have 0 CHF, and my choices are “Sell” or “Receive”. But if I have 0, how can I sell some? and it says that I have to identify myself before I can make a deposit, so I should not be able to receive any?

.

Let’s start the KYC. I choose Mt Pelerin for the KYC provider. The app asks me to identify with my finger (no option to choose password instead if I burned my finger or my device is broken ?)

.
But the KYC doesn’t appear after authentification and next screen is main screen (wallet).

That’s all for tonight folks.

Usefull informations for debugs :
Pocophone F1, Sim cards FR and CH.
Android version 9 PKQ1.180729.001

1 Like

Hello,

Here is the first day feedback.

  • Like many I got the crash after creating a new seed without the possibility to see the seed.

  • I also got a crash of the application on the first screen when creating a password and using Lastpass auto-filling, my phone switched to Lastpass app and when coming back Wallet crashed.

  • When starting app the image is not full screen and I have a black border around.

  • Android notification icon is the Ibani logo :wink:

  • When performing identification the app is requesting for fingerprint but when providing finger I was not able to continue the process. After clicking “Cancel” I was able to enter the phone number and continue the process. Seems the fingerprint authentication is not needed there and not working anyway.

  • At the SMS code screen it would be good to be able to “paste” the code. I copied it from the SMS but was not able to paste and had to manually enter it.

  • At the photo for identification the app was very slow and frozen for a moment. I have a Huawei P30 Pro so it was surprising to have so much lag. However after a moment the app unfrezzed and I was able to take the photos.

  • When navigating in the settings, under “Profile” and selecting a menu like “Documents” and then going back with the left corner arrow I am directly redirected to the main settings menu and not the previous page.

  • When navigating back in the settings menu the bottom Dock with the icons disappear.

  • The activity screen is not refreshing automatically and a swipe down don’t start a refresh. For the moment the only way I found to refresh this screen is to restart the application.

  • When changing the language in the settings some parts of the app are not refreshed and still displayed with previous language until restarting the application.

  • When scanning an Ethereum address, the app give a feedback that it was able to read the QR code but the address is not filled in the app.
    Also on some screens like the below screen you see the content is all displayed in the top of the screen and is very close to the android top notification bar where the bottom of the screen is full of blank space. You may add a border on the top of the app and center more the content.

  • When purchasing MPS it is a sell order that is sent.


  • I tried to attach a new address but even both confirmation transactions are done the address is not confirmed. By the way all wallets set 21000 gas limit by default to send eth but your destination smartcontract required 21081 gas to execute so it fail out of gas if not manually changing gas limit when sending the confirmation transaction.
    Also in the confirmation screen it is not possible to copy the amount and the addresses so I had to manually type the address and the amounts in my wallet, this is not fun :stuck_out_tongue:
    In a side note, any plans to use ENS addresses ?

  • About the experience when performing transactions.
    After a transaction you get a green bar on top but I think it would be best to get a kind of confirmation screen mentioning transaction is pending with a link to the tx, this screen may auto-refresh when transaction completes confirming is completed or we may want to go back and continue using the app.
    Then currently after doing a transaction you continue navigating in the app and you brutally get a popup informing transaction is completed but it break a bit the experience.
    Also when performing multiple actions and they are all confirmed on chain you get multiple popup but don’t know what transaction have passed and what it was about, if app is closed we get multiple android notification mentioning successfull transaction without details also. Globally in this notifications and popups it is missing a short description of the action like “Your 1 MPS sent/buy/sell has been confirmed” or “10 M-EUR has been sent/received”, etc.
    The redirection to etherscan is good but I think it should be a manual step for geeks that want to check the details by clicking on the transaction, by default the app should not automatically redirect to etherscan page in any circumstance. I notice after some actions like hitting OK on the popup I was automatically redirected to etherscan and it also breaks a bit the experience of the app.

  • To conclude I didn’t played much with it yet but the very first feeling on buy and sell of assets was confusing. I think this needs two separated places : One with only market buy and market sell at the best available price for a very easy experience (next to the receive and send like of now).
    But we may need a separated screen with advanced settings and a light trading experience with a chart, an orderbook, advanced trading settings, etc…

Good night and good luck with the improvements of the app :slight_smile: Can’t wait to see it evolve during the beta testing.
Don’t hesitate to contact me on telegram @Folkaio if something I reported is not clear.

1 Like

Well done guys :slight_smile:
Good to read everyones feedback!

I agree on a lot of points stated above ^^

1 Like

Got my other account added, and now download complete. Thank you!

Quick feedback on KYC process.

  • Mentioned by others, but starting the KYC prompts fingerprint authentication, and KYC stops and returns to wallet page after verifying fingerprint.
  • KYC page loads if I press cancel in the fingerprint authentication
  • Anytime choosing a country (for phone number or for country of residence), the alphabetical short cut on the right of the screen does not work and I need to scroll the screen manually instead of jumping to the alphabet of choice.
  • KYC information upload process itself is smooth